Windows 10 Setup не вижда SSD-то

15 мнения в тази тема

Публикувано

Здравейте хора, пред голямо уау съм от няколко дни, и имам нужда от всякакви идеи и съвети. Първо накратко ще обобщя проблема, след което ще навляза надълбоко. 

Става на въпрос за лаптоп Lenovo Idepad S145-15ikb с 8о поколение I3 процесор, останалите параметри не са толкова важни, колкото основния диск, които е SSD, и то не какво да е, а PCIe WD PC SN520 Nvme, и от тук идва целия проблем. По време на инсталация на Windows, всичко върви гладко, до момента в който не ми изписва, че няма налични драйвери за диска, и съответно не мога да продължа инсталацията, рових се из биос, като опции на диска имам само Ahci и RST (Intel Rapid Storage), като няма значение на коя от 2те съм, инсталацията на Windows, не вижда харда, а в биос харда се вижда единствено, като избера RST опцията, съответно след като е избера, Биоса се заключва само в Uefi режим, но това няма нищо общо, понеже нямам проблем с буутването от флашка, общо взето без значение в Биоса под каква опция е диска, инсталацията на Windows 10 го вижда, без значение дали е на Uefi или Legacy, също не го вижда и търси драйвери. Намерих драйвери от сайта на Lenovo и Интел, но не ги харесва, и ми изписва, че не са съвместими, и следователно също не мога да продължа... Някакви идеи?

И да  направим разбор:

Опитах с 3 различни флашки, с 3 различни Windows образа, дори и Windows 7, всичките стигат до едно и също място, и всичките не виждат диска, пробвано е да се конвентира диска от MBR към GPT и обратно, същи не го вижда, пробвано е и флашките с Windows-ите на GPT и MBR, отново без резултат, единственото място на което виждам ссдто е в Биос при настройка на RST и като обърна на Legacy, но отново при инсталация го няма.. След доста четене стигнах до извода, че може би му трябва така наречения Nvme драйвер, но увисвам с търсенето на такъв, понеже намирам само за Samsung и Intel SSDта, но не и за въпросния WD... Отделно си нямам никаква идея, като намеря драйвера как да го инсталирам по време на инсталация на Windows, може би трябва някак си да го вмъкна в ISO образа... Приемам всякакви идеи, че от 3 дена увиснах, и не знам какво да го правя.... 

2

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Ще трябва да интегрираш Nvme драйверите предварително в инсталационната флашка или ISO. Подробно съм описал процеса в този урок: https://windowsbulgaria.com/tutorials/article/90-инсталиране-на-windows-7-на-нов-хардуер/

4

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено (Редактирано)

Направо пускам да се тегли готовото ISO в темата която си дал, по-късно ще видим дали има развитие по темата..

ПС: Въпросната 7ца с интегрираните драйвери си се прави под легаси нали? 

Редактирано от MirkO95
0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Ами мисля, че е за UEFI, но може би ще стартира и под Legacy, зависи как ще направиш флашката, то това е само начина на буутване, не е свързано с начина на инсталация.

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

За жалост тъпия лаптоп не разпознава флашката с готовия образ на Windows 7, нито под Legacy, нито под Uefi... Стигаме до другия въпрос, разпознава я единствено, ако е създам със инструмента на Microsoft, където сам си тегли Windows 10 и сам си прави флашката, ако ги правя с руфус или друга програма, въобще не ги зачита... Как да интегрирам драйверите във вече направена флашка? Нямам install.wim само boot файла... 

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено (Редактирано)

Ами вариантите ти са да ползваш и пробваш други инструменти за създаване на инсталационна флашка, например UltraIso Portable ИЛИ да инсталираш през портативната система на Стрелец. Урок тук: https://windowsbulgaria.com/tutorials/article/81-използване-на-буутващa-winpe-флашка-за-инсталиране-на-windows/ . Ако ползваш инструмента Setup Win7-10 и моето ISO, съветвам те да избереш инсталация от ISO. Аз всъщност от години не правя флашки за инсталиране, а ползвам само една флашка - тази от този урок и си маунтвам исо-то и инсталирам. :) 

Редактирано от Иванов
3

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Пробвай да оправиш нещата с диск на WinPE 10-8 Sergei Strelec.

 

3

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено (Редактирано)

В момента тегля Англииска версия на 10ката, че очевидно стрелеца не се разбира с Българските и след разархивиране на файловете на Windows ми дава грешка 0х80000001, доколкото чичо Гугъл каза, проблема е в езика, малко по-късно ще пиша за развитие по темата, за момента единствения ми вариант е Streleca...

 

 

ПС: Стрелец дъ бест! Успешно инсталиран, вече имаме работещ Windows 10

Редактирано от MirkO95
7

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено (Редактирано)

любима комбинация за инсталиране на машини - Strelec+WinNTSetup

Редактирано от ExaFlop
4

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

WinNTSetup е за напреднали потребители, тъй като изисква предварително подготвени дялове. Не го препоръчвай винаги, защото не всеки би се справил. :)

4

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено (Редактирано)

WinNTSetup в Strelec има подготвени скриптове с различни сценарии за diskpart. Така, че проблемът с дяловете мисля, че не е на дневен ред. Освен това там има N инструмента за работа с дялове. А и драйвърите можеш да си инжектираш, и регистрови скриптове....
Освен това аз не задължавам никого да ползва. Казвам само как инсталирането става лесно като 1, 2, 3.
А и никой не се е родил научен.

Редактирано от ExaFlop
8

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Искам да направя ЪП на темата, само аз ли имам този проблем отново и отново, без значение от компютърната конфигурация и USB флашката? Преди малко си направих нормална флашка MBR за обикновен SATA хард диск, и също не го разпозна, при условие, че е на 2.0 порт и флашката също... релайза на 10ката е 2004, в момента правя с 1909 да видим дали ще има промяна, дооста интересно...

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

А някакво инфо за лаптопа/дъното?

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено


Имам съмнения, че се случва нещо с Rufus-а, понеже личния ми компютър си е старо ddr2 дъно, и досега не съм имал проблем със намирането на хард-а, за пробата на още 2 компютъра, същата работа... може би самия руфус нещо маже положението, защото при Windows 7 е същата история, единствено с Win7 USB/DVD Download tool и Strelec-а виждам дяловете...

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено (Редактирано)

Старо, старо, колко да е старо...

Аз правих преди месец горе-долу чиста инсталация на Windows 10 2004 с флашка, правена с Media Creation Tool на Микромеките и инсталацията не видя контролера и дисковете, докато не пуснах в биоса контролера в IDE режим вместо AHCI....

Конфигурацията е десктопа от подписа ми.

Дали да не се обзаложим дали нямаш същия проблем, а? ;)

Изглежда Микромеките изхвърлят от всяка следваща версия на Windows (и съответно инсталациите им) хардуер, който вече може да мине спокойно към музея. :)

Редактирано от Филип Петев
4

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Създайте нов акаунт или се впишете, за да коментирате

За да коментирате, трябва да имате регистрация

Създайте акаунт

Присъединете се към нашата общност. Регистрацията става бързо!


Регистрация на нов акаунт

Вход

Имате акаунт? Впишете се оттук.


Вписване